• Herzlich willkommen im Volkswagen T-Cross Forum. Die Teilnahme am VW T-Cross Forum ist kostenlos. Eine Fülle von Informationen über das brandneue Polo-SUV von Volkswagen warten auf dich.

    Der VW T-Cross ist der kleine Bruder des beliebten VW T-Roc. Hier in unserer Community findest du Bilder, Reviews, Tipps & Tricks, Hilfe, Infos zu Kinderkrankheiten und vieles mehr zum T-Cross.

    Registriere dich oder melde dich mit deinem Benutzernamen an um eine Frage zu stellen oder Antworten zu geben.

GPS-Navigation funktioniert nicht mehr wegen falsch erfasster Himmelsrichtung

elessar

War schon mal da
Hallo zusammen,
seit ca. 16 Monaten bin ich auch (stolzer?) Besitzer eines T-Cross* (gebraucht mit 23000 km aus 2021). Soweit bin ich mit dem Fahrzeug sehr zufrieden. Man muss sich halt ein bisschen an das diesel-ähnliche Fahrgeräusch eines Dreizylinders erst gewöhnen wenn man den zum ersten mal fährt.
Es war bislang auch alles gut.
Jetzt allerdings funktioniert die Fahrtrichtungserkennung für den Navi nicht mehr.
Wir benötigen den Navi nur selten, haben bislang damit aber keine Probleme gehabt. Jetzt allerdings wird die Fahrtrichtung für den Navi und somit auch für die Kompassanzeige nicht mehr richtig erkannt.
Bei einer konstanten Fahrtrichtung springt der Kompass immer wieder auf eine Fahrtrichtung um Norden. Auch wenn keine reale Änderung der Fahrtrichtung vorgenommen wird.
Bei Fahrtrichtungsänderungen (z.B. Abbiegen an einer Kreuzung) ändert der Kompass zwar kurz die Richtung relativ zu seiner letzten Richtung und springt dann wieder schnell zurück auf in etwa Norden (mit starken Schwankungen als ob man dauernd im Zickzack fährt). Die zurück gelegte Strecke scheint aber zu passen.
Ein Reset (langes Drücken des Aus-Knopfes am Media-Center) hat keine Änderung gebracht.
Auch habe ich mir mal die Anschlüsse an der 3fach-Antenne (Radio, GPS, GSM) im Dach angeschaut (Dichtung der Heckklappe raus und Himmel hinten gelöst). Da hab ich keine losen Verbindungen gesehen.
Meine Frage:
Kennt jemand solches Fehlerbild?
Hängt die Fahrtrichtungserkennung nur von der GPS-Antenne ab oder hängt da auch noch dieses GCU-Steuergerät mit drin?
Besten Dank im Voraus für ein paar Ideen wo ich suchen könnte.
Die Garantie ist mittlerweile leider abgelaufen und ich würde gerne mit ein bisschen mehr Hintergrundwissen zur Werkstatt gehen.
 

Ralf25

Stammuser
Der Kompass funzt ja auch im Tunnel und das geht nur über spezielle Sensoren im Fahrzeug selber. Das GPS-Signal hingegen hat grad deshalb damit nix zu tun, weil es Laufzeitunterschiede zwischen den Signalen verschiedener Satelliten zur Positionsbestimmung benutzt. Und die kann man eben nicht so einfach wie Radio- (nur vereinzelte freq.) oder Handy*-Freq. per SIgnal-Kabel/-Antenne in die Tunnel leiten. Da kann man manchmal die dicken Kabelstränge (Funkkabel) dafür sehen, oft an der Decke montiert.

Bei dir scheint also das spezielle Modul (= einzelnes Bauteil) defekt zu sein.
 

Matador 8

Ist öfter hier
Ich würde auf die OCU (Online Connectivity Unit) tippen. Prüfen lassen, mit etwas Glück ist es vielleicht mit einem Update getan. Falls nicht, kann eine Frage nach Kulanz nicht schaden.
 
Zuletzt bearbeitet:

elessar

War schon mal da

Besten Dank erstmal für die schnelle Rückmeldung.
Das mit dem Tunnel ist ein guter Gedanke. Damit würde die GPS-Seite ja schon mal ausscheiden... Hätte man durch nachdenken ja auch selbst drauf kommen können :oops:.
Zudem ist es so, dass scheinbar in bestimmten Zyklen (so gefühlte 2 - 3 Minuten) das Navi wieder auf die richtige Position springt. Dann geht's aber sofort wieder nur in nördlicher Richtung weiter.
Scheinbar holt sich das Navi die Position immer nur in zeitlichen Abständen vom GPS. Dazwischen wird scheinbar mit Himmelsrichtung und Geschwindigkeit interpoliert.
Dann nehme ich das mal als Anregung mit. Mal sehen, von wo der Kompass seine Informationen bekommt. Wenn es die OCU (nicht GCU :geek:) ist, wird es hoffentlich überschaubar bleiben.
Ergebnisse werde ich posten.
Danke nochmal
 

Ralf25

Stammuser
Das mit dem Tunnel ist ein guter Gedanke. Damit würde die GPS-Seite ja schon mal ausscheiden...
Auf'm recht aktuellen Smarty kann man das auch gut beobachten. Zunächst muss der Kompass meist zu Beginn oder später bei Abweichungen (neu) kalibriert werden, aber dann sollte der GPS-Positionspfeil/-strahl immer in dieselbe Richtung zeigen wie das Smarty auch.
Als Fußgänger in fremder Umgebung ist das sehr hilfreich zur Orientierung! (y)
 

Ralf25

Stammuser
@bab Ich hab sein Problem so verstanden, wie wenn nur der Fahrtrichtungsanzeiger (Kompass) nicht korrekt arbeitet, die Navigation als solche aber schon; trotz des etwas unglücklich formulierten Themas.
Doch zum genauen Fehlerbild kann uns der TE ja am besten berichten. Vlt. hatte er ja auch schon Kontakt zum :).
 
  • Like
Reaktionen: bab

elessar

War schon mal da
Anzeige

Ja, so nehme ich das zumindest auf. Die Bewegung auf dem Navi (auch wenn keine Navigation gestartet ist, also nur auf der Karte) wird auf die richtige Entfernung aber in die falsche Richtung dargestellt. Somit würde die Funktion des Navi, also das zum Ziel leiten vom aktuellen Standort eigentlich funktionieren. Vielleicht wirklich etwas missverständlich ausgedrückt.
Aber da der Navi die meiste Zeit die aktuelle Position falsch darstellt ist eine Zielführung natürlich für'n ...
Termin dauert noch. Mal sehen was bei rauskommt
 

elessar

War schon mal da
So, heute war der T-Cross* in der Werkstatt.
Das beste vorweg:
Der Fehler ist bekannt und es gibt eine vorgegebene Handlungsanweisung für die Werkstätten.
Das Ganze ist laut Werkstattauskunft ein Softwarefehler. Zu beheben durch ein Update des Navi selbst und der "Notruf-Unit"
Ist das die OCU?
Jetzt ist der Wagen gerade 4 Monate aus der Garantie und somit wurde von Seiten VW eine Kulanzregelung abgelehnt.
Bin ich doch ziemlich angesäuert drüber. Ein Softwarefehler der durch ein Update behoben wurde. Also kein Defekt am GPS oder
anderweitiger Hardware. Und trotzdem wird Kulanz abgelehnt. Kein wirklich gutes Argument für VW.
Aber vermutlich gehen andere Hersteller mit so etwas vergleichbar um.
 

Matador 8

Ist öfter hier
Ja, die Notruf-Unit hängt mit der OCU zusammen.

Wurde dem Fahrzeug in jüngster Vergangenheit ein OTA-Update für die OCU und das Infotainmentsystem angeboten? Prüfe bitte mal hier ob für das Fahrzeug eine Servicemaßnahme aufgeführt ist.

4 Monate nach Gewährleistungsende für ein Softwareupdate, dass zur Beseitigung einer Fehlprogrammierung erforderlich ist, zahlen zu müssen, ist schon happig. Ich würde mich in dieser Angelegenheit direkt an VW wenden, bei direkten Kundenbeschwerden reagiert das Unternehmen vielleicht doch noch anders. Um welchen Betrag geht es überhaupt?
 

elessar

War schon mal da
Hallo,
ich hab das gerade mal geprüft unter dem angegeben Link. Demnach ist keine Servicemaßnahme oder Rückrufaktion für das Fahrzeug gelistet.
Kann ich irgendwo ohne tieferen Zugang in das Menü der Bedieneinheit einen Updateverlauf auslesen?
Die Kundenbetreuung von VW habe ich gestern bereits angeschrieben und meine Sicht der Dinge dort dar gelegt. Mal sehen wie lange
auf eine Reaktion zu warten ist und wie die ausfällt.
Das Ganze hat mich 175€ gekostet. Ist noch verschmerzbar aber für eine Behebung eines Softwarebugs der zu Funktionsausfall führt find ich das frech.
 

Hypercosinus

Vielschreiber

@elessar
Halte mal ca. 5 Sekunden lang die Menü-Taste gedrückt.

In dem dann erscheinenden versteckten Menü steht die installierte SW Version des MIB und ein Update Log. Es wird dir allerdings nicht viel helfen und dient nur zur Info.
 

elessar

War schon mal da
Werde ich mal nachschauen.
Bis zu irgendeinem Zeitpunkt hat das ganze ja funktioniert. Wenn es OTA-Updates in der Zwischenzeit gegeben hat und nachdem dann unter Umständen die Funktion des Navi kaputt-optimiert wurde, wäre das ja noch ein Argument mehr, die Rechtmäßigkeit eines kostenpflichtigen Bugfixes zu beanstanden.
 

rscobra

Ist öfter hier
magst du mir mal deine fahrgestellnummer, gerne per pn, schicken?

ich könnte dann im vw system nachschauen.
das update hört sich nach einer feldaktion von vw an und die sind eigentlich kostenfrei.
die sollten auch über ota kommen, dies geht aber nicht immer.
war bei meinem auch so und wurde in der werkstatt dann über den tester eingespielt, kostenlos.
 

* = Affiliatelinks/Werbelinks
Die mit Sternchen (*) gekennzeichneten Links sind sogenannte Affiliate-Links. Wenn du auf so einen Link klickst und über diesen Link einkaufst, bekommen wir von dem betreffenden Online-Shop oder Anbieter eine Provision. Für dich verändert sich der Preis nicht.

über das t-cross forum

Das VW T-Cross Forum dient dir als Plattform um mit anderen stolzen T-Crossfahrern Erfahrungen auszutauschen zu können.
Bei offenen Fragen rund um den T-Cross stehen dir Gleichgesinnte aus unserer Community mit Rat und Tat zur Seite. Du bist auf der Suche nach der Lösung eines bestimmten Problems? Dann wende dich mit deiner Frage an unser Forum oder nutze einfach die Suchfunktion, um eine Übersicht über alle bereits vorhandenen Themen zu deiner Fragestellung zu bekommen.

Egal ob Kinderkrankheiten, Elektronik- oder allgemeine Probleme mit dem VW T-Cross – wir haben ein Forum geschaffen, dem es an nichts fehlen soll.

Oben Unten
Warum sehe ich das Forum nicht?

Du siehst diese Meldung, weil du einen Adblocker eingeschaltet hast. Deaktiviere ihn bitte für t-crossforum.de, um unsere Artikel wieder lesen zu können.

Alternativ - REGISTRIERE DICH KOSTENLOS. Aktive Mitglieder sehen weniger Werbung und haben uneingeschränkten Zugriff auf unser Forum.

Du bist bereits Mitglied? Dann logge dich HIER ein!

Adblocker wurde deaktiviert